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HTTP 502.3 "Bad Gateway" error messages appear after a two-minute delay when loading the NuGenesis WebVision client - WKB31372

Article number: 31372

SYMPTOMS

  • The NuGenesis WebVision site is very slow to load
  • When opening a project view, the browser displays an error message HTTP 502.3 "Bad Gateway"
  • In the Microsoft IIS log files, the log for the WebVision site contains the error codes 502.3 and 12002 for at least one client request, and the time-taken value for the request is approximately 120000 (120 seconds)
  • No error messages are recorded in the Apache Tomcat log files, and the Apache Tomcat 6 service is running

ENVIRONMENT

  • NuGenesis 9 SDMS
    • Microsoft IIS in Windows Server 2016 / 2019
    • Apache Tomcat v9.x
  • NuGenesis 8 SDMS
    • Microsoft IIS in Windows Server 2012
    • Apache Tomcat 6.0.29

CAUSE

The codes 502.3 and 12002 mean that IIS hit a timeout period while waiting for a response from the proxy server (Apache Tomcat). The timeout is 120 seconds by default. The timeout could be a failure of the Apache Tomcat service, slow performance of the server as brought on by debug logging in NuGenesis SDMS, or slow performance/no response from the Oracle database(s) for NuGenesis.

FIX or WORKAROUND

  1. Check the status of the Apache Tomcat 6 service on the NuGenesis SDMS web server; it must be Started or Running.  Restart the Tomcat service
  2. Look for recent error messages in the Tomcat log files: Drive:\Program Files (x86)\apache-tomcat-6.0.29\logs
  3. Disable debug logging and restart the services:
    1. Open regedit and look for the registry keys for SDMS debugging:
      • NuGenesis 8: HKLM\Software\Wow6432Node\NuGenesis Technologies Corp.\NuGenesis\8.0\Debug
      • NuGenesis 9: HKLM\Software\Wow6432Node\NuGenesis Technologies Corp.\NuGenesis\Debug
    2. Delete the "Debug" key if it is present
    3. Close regedit
    4. Open the services control panel: Start > Run > services.msc
    5. Stop the Apache Tomcat and World Wide Web Publishing services
    6. Restart the service NuGenesis VISION Server
    7. Start the Apache Tomcat and World Wide Web Publishing services
    8. Restart the NuGenesis RPC service
    9. Delete the debug logs to free up space on the server's disks:
    10. Delete the Apache Tomcat log files:
      • Drive:\Program Files (x86)\Waters\apache-tomcat-x.y.z\logs
  4. Restart Internet Explorer and log back in to Web Vision
  5. Log in to SDMS Administrator and verify that all of the databases in the Master and Local lists are online and accessible.  If one or more of the databases ae inaccessible - that is, SDMS Admin becomes unresponsive when logging in to a database - then the DB is likely down and needs to be restarted
  6. If the Oracle database for NuGenesis is online/accessible but performing slowly—often the result of an inadequately sized SGA or insufficient indexes—timeouts and HTTP 502 errors will result.  Contact Waters Technical Support for tools and assistance in troubleshooting the database's performance

ADDITIONAL INFORMATION

HTTP 502.3 errors may also occur if the Java Runtime Environment on a NuGenesis 8 web server is updated beyond Java 1.7 Update 2. The newer JRE is not compatible with Apache Tomcat and prevents it from responding to IIS, leading IIS to display the 502.3 error code in the browser.  Java upgrades for NuGenesis 9 SDMS web servers are supported per the instructions in the linked article.

id31372, SDMS, SDMS8, SDMS8NU, SUPISDMS, SUPNG

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