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HTTP 502.3 "Bad Gateway" error messages appear for some NuGenesis users after a 2-minute delay when loading SDMS WebVision - WKB233236

Article number: 233236

SYMPTOMS

  • The NuGenesis WebVision site is very slow to load for some, but not all, users
  • When opening a project view, the browser displays an HTTP 502.3 "Bad Gateway" error message
  • In the Microsoft IIS log files, the log for the WebVision site contains the error codes 502.3 and 12002 for at least one client request, and the time-taken value for the request is approximately 120000 (120 seconds)
  • Error messages are recorded in the Apache Tomcat log file and the Apache Tomcat service is running

ENVIRONMENT

  • NuGenesis 9 SDMS
  • NuGenesis 8 SDMS

CAUSE

The NuGenesis database was refreshed by means of a database export/import, or the database was the target of a migration from an earlier version of NuGenesis. The user preferences in the SDMS database contain references to another database, and the SDMS Web server is unable to connect to that database.

FIX or WORKAROUND

Configure the SDMS web server so that it can connect to all SDMS databases, even if only on a temporary basis, so that users can log in via WebVision and click Tools > Clear recently viewed projects list.

ADDITIONAL INFORMATION

 

id233236, SDMS, SDMS8, SDMS8NU, SUPISDMS, SUPNG

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