Skip to main content
Waters

My files are not being captured by SDMS, but there are files in TE_TEMP - WKB2409

Article number: 2409

SYMPTOMS

  • Files were placed in a scan path (ex:\\Filesserver1\shareddata\) for archiving by NuGenesis, but the files are not visible in WebVision. There are files in TE_TEMP, the pending files location for the NuGenesis file capture process.

ENVIRONMENT

  • NuGenesis 9 SDMS
  • NuGenesis 8 SDMS
  • Files are ready for capture by SDMS
  • Per the Archive Agent's activity log, the files were captured by the AA
  • Several files exist in the TE_TEMP folder on the SDMS server

CAUSE

Files normally exist only for short periods of time in the TE_TEMP folder. The NuGenesis Archive Agent copies files into that folder during the file capture process, and the Transport Engine module moves the files from TE_TEMP into the database or into Managed Storage. Files that persist in this directory indicate that the TE module is stopped or that failures occurred during the transfer of files to the Oracle database or to Managed Storage.

FIX or WORKAROUND

Look for .mark_bad files in the NuGenesis TE_TEMP folder

  1. If there are no .mark_bad files in TE_TEMP:
    1. Log in to the NuGenesis Service Configuration Console on the NuGenesis server and start the Transport Engine module
    2. If starting the TE module does not resolve the problem, restart the NuGenesis RPC service on the NuGenesis server
  2. If there are .mark_bad files in TE_TEMP:
    1. Rename the files back to .NGD
    2. If the files get renamed back to .mark_bad after a short delay, restart the NuGenesis RPC service
    3. If the problem persists after a service restart, then open the .mark_bad file with the most recent Modification date in Notepad and scroll to the end of the file.  Look for an NG error code, of the form [NGXXXXX]

ADDITIONAL INFORMATION

The TE_TEMP folder is normally set within the NuGenesis installation path on the server. For example:

  • NuGenesis 9: Drive:\Program files (x86)\Waters\NGSDMS\TE_TEMP
  • NuGenesis 8: Drive:\Program Files (x86)\NuGenesis 8.0\TE_TEMP

The TE_TEMP location is a configurable setting. If you are unsure of the TE_TEMP path, log in to the NuGenesis Service configuration Console on the NuGenesis server, and select the Archive Agent module. Click OK to a warning message if one appears. The Metadata Folder text box will have the complete path to the TE_TEMP folder as used by the file capture modules. Also note: the folder need not be named TE_TEMP. That name is just the default name. Another common name is "Pending".

If the TE_Temp location has a large number of .mark_bad files use the CMD prompt to change the file extension to .ngd.

  • Open a Windows CMD prompt, change the directory to the TE_Temp location. Example: (Drive:\Program Files (x86)\NuGenesis 8.0\TE_TEMP
  • At the CMD type ren *.mark_bad *.ngd
  • This changes all the mark_bad extensions to .ngd

id2409, SDMS, SDMS8, SDMS8NU, SUPISDMS, SUPNG

Not able to find a solution? Click here to request help.