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Error "The NuGenesis RPC service on Local Computer started and then stopped" appears when starting the NuGenesis RPC service - WKB60338

Article number: 60338

SYMPTOMS

  • The following error message appears when starting the NuGenesis RPC service:
    • The NuGenesis RPC service on Local Computer started and then stopped. Some services stop automatically if they are not in use by other services or programs.

ENVIRONMENT

  • NuGenesis 9 SDMS
  • NuGenesis 8 SDMS
  • Windows 10

CAUSE

  • A file, possibly msvcr100.dll, is not installed on the client machine; OR
  • The service account doesn't have sufficient rights on the system; OR
  • Prior to NuGenesis 9.1, the ImagePath registry key was manually modified to include double-quotes

FIX or WORKAROUND

  • Missing files:
    1. Run the UNIFY Auto IQ and inspect the log file for failed or missing files and registry keys
    2. Copy the file C:\Windows\Syswow64\msvcr100.dll from another machine to this folder on the client machine
    3. Restart the NuGenesis RPC service
  • Service account:
    • For client machines, the NuGenesis RPC service can run as LocalSystem (default) or as NetworkService, provided that some permission changes are made as per the linked article.  NetworkService is preferred on client machines due to it's inherently reduced set of privileges vs. LocalSystem
    • For a server running the Archive Agent / Transport Engine / Data Management / OSM modules, the RPC service should run as a Domain user account, with the privileges as specified in the linked article
  • ImagePath in quotes:

ADDITIONAL INFORMATION

 

id60338, SDMS, SDMS8, SDMS8NU, SUPISDMS, SUPNG

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