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Error: "Document <ID> is not created yet !" "System.Exception: Could not open Excel/Word process" from the NuGenesis Document Creator Service - WKB22000

Article number: 22000

SYMPTOMS

  • Documents that should be created by the Document Creator Service are not created.
  • Clicking a document link in LMS Sample Management results in the message "Document <ID> is not created yet !"
  • The following error message appears in the DCS's log file:
    • "Could not open Excel/Word process"

ENVIRONMENT

  • NuGenesis 9 LMS
  • NuGenesis 8 LMS
  • NuGenesis 8 ELN
  • NuGenesis LEME or Smart Builder
  • Microsoft Office 2010, 2013, 2016, 365

CAUSE

A message box appears in Word or Excel when the DCS tries to open the processes. Any message box prevents the winword.exe/excel.exe processes from responding to the DCS service and results in this error.

FIX or WORKAROUND

  1. Identify the user account for the "NuGenesis LMS Document Creator" service.
    • This service must run with a named user account, not LocalSystem.
  2. Log in to the DCS server as the DCS user.
  3. Open Microsoft Word.
  4. Look for and dismiss any dialog boxes or message boxes displayed by Word.
  5. Close Word and open Microsoft Excel.
  6. Clear any message or dialog boxes from Excel.
  7. Open the Excel Options window and clear the following checkboxes:
    • Tell me if Microsoft Excel isn't the default program for viewing and editing spreadsheets.
    • Show the Start screen when this application starts.
  8. Close Excel.
  9. Restart the "NuGenesis LMS Document Creator" service.
  10. Log out of the DCS server.

ADDITIONAL INFORMATION

Requirements for the DCS:

  • 32-bit Office must be installed on the server that hosts the Document Creator Service. This service may be hosted on any machine, not just the LMS Application (JBOSS) Server. 64-bit versions of Microsoft Office are not supported. The versions of Office supported for a given version of NuGenesis are stated in that version's release notes.
  • Microsoft Office must be fully activated. The automation routines used by the DCS do not work if Office is not activated.
  • The service account must log in at least once and run Excel in order to answer the request for user info and to approve the installation of any Excel add-ins, if present. Any message box prevents the automation routines from working. In Office versions 2010 and later, every user must approve each Excel add-in when they load Excel for the first time.
  • The ELN/LMS user account in the DCS configuration should be member of all LMS departments. The default user account is SYSTEM.
  • Within Excel, allow macro settings without notifications. Otherwise, the excel.exe processes become stuck and no documents are created. This setting is machine and user specific. So this setting has to be done on the machine where the DCS is running, logged in with the user running this service.

id22000, ELN, NGLMS, NGLMSLIC, NGLMSOPT, SUPNG

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