Error "This file does not have an app associated with it..." when using the Open With button in the Renditions Selection Form in NuGenesis LMS Section Management - WKB79258
SYMPTOMS
- The following error message appears when clicking the Open With button in the Renditions Selection Form:
- Title: C:\Users\username\AppData\Roaming\Waters\NuGenesis LMS\9.0.0.0\temp
- This file does not have an app associated with it for performing this action. Please install an app or, if one is already installed, create an association in the Default App Settings page.
- The Open With dialog box does not appear
ENVIRONMENT
- NuGenesis 9 LMS
- NuGenesis 8 LMS
- Windows 10 or Server 2016
CAUSE
The default handler for files of unknown type is not registered within Windows.
FIX or WORKAROUND
Use the attached registry file to register the "OpenWith.exe" program with the "Unknown" file type in Windows.
ADDITIONAL INFORMATION
In some cases the default value for the registry key "HKCR\Unknown\shell" was set to "OpenOnline openas". This value prioritizes the OpenOnline key—which directs Windows to look for a program online—over the "openas" key. In Windows 10, "openas" directs to the program "OpenWith.exe". Setting the default value back to openas is typically all that's needed to restore the functionality. This change is also incorporated into the registry file. The root cause—that is, why the key prioritizes "OpenOnline" vs. opening locally by default—is not known.
id79258, NGLMS, NGLMSLIC, NGLMSOPT, SUPNG