The archive bit is not being reset on files captured by the NuGenesis Archive Agent - WKB7620
Article number: 7620
SYMPTOMS
- Files are not properly captured by NuGenesis SDMS
- The following messages appear in the SDMS Archive Agent's activity log file:
- ResetArchiveBit. Failure to reset archive bit for file \\servername\sharedfolder\path\filename.ext
- Cannot reset archive bit. As per user's settings, Performing Rollback.
ENVIRONMENT
- NuGenesis 9 SDMS
- NuGenesis 8 SDMS
CAUSE
The NuGenesis RPC service user does not have permission to change the attributes of files.
FIX or WORKAROUND
- Identify the NuGenesis RPC service user.
- Log in to the machine where the files are stored and browse to the shared folder
- Open the Properties page of the shared folder and click the Security tab
- The NuGenesis RPC service user should be listed on this tab and have, at a minimum, Read and Write permissions on the folder
- Delete permissions are necessary if the files should be deleted by NuGenesis Data Management
- Add the service user to this list, grant Read and Write permissions, and propagate this permission to all subfolders
- Repeat steps 1 through 5 for all shared folders that will be scanned by the NuGenesis Archive Agent
ADDITIONAL INFORMATION
Adding the NuGenesis RPC service account to a Domain Administrators group is not recommended. This group membership gives the account full control over all shared files/folders by default, on all machines, which is a security risk. Limit the service account to only the permissions it needs: Read, Write, and, optionally, Delete on the shared folders that are to be scanned by NuGenesis.
Remove the READ-ONLY attribute on all folders, including subfolders.
id7620, SDMS, SDMS8, SDMS8NU, SUPISDMS, SUPNG