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My files are not deleted after archiving into NuGenesis SDMS - WKB72360

Article number: 72360

SYMPTOMS

Files that were archived into NuGenesis SDMS and set for deletion are not deleted.

ENVIRONMENT

  • NuGenesis 9 SDMS
  • NuGenesis 8 SDMS
  • One or more template lines are configured in an SDMS Archive Template with the Deletion Protocol set.

CAUSE

The most common reasons for DM not deleting data is that the DM module is stopped or the Deletion Protocol was set incorrectly in the SDMS Archive Template when the files were archived.

FIX or WORKAROUND

  1. Ensure that the Data Management module is started:
    • Log in to the NuGenesis Service Configuration Console (SCC)
    • Confirm the status of the Data Management module and start the module if it is stopped
  2. Confirm the Delete Protocol in the template:
    • Log in to SDMS Administrator
    • Open the Master List and select the appropriate project
    • Open the project properties and click the Templates tab
    • Select the appropriate archive template and click Edit
    • Select one of the active lines in the template and take note of the Delete Protocol
      • The deletion protocol defines the time period when the data becomes a candidate for deletion. The system sets the deletion candidacy date for the data based on the protocol settings, either a specific period of time after the data's modification date or a period of time after the data's archive date.
      • Some data adapters have deletion protocol criteria which is specific to the adapter.  For the Empower data adapter, the only option is "After Project Modified", whereas that option does NOT apply to other adapters, such as NuGenesis Generic or Adobe PDF
      • Here are some examples:
        • 2 Years After File Archived (does NOT apply to Empower or Chromeleon)
        • 3 Months After File Modified (does NOT apply to Empower or Chromeleon)
        • 4 Days After Project Modified ("Project Modified" applies only to the Empower data adapter)
      • The Archive Agent calculates the data's deletion candidacy date using these settings when it archives the data.
      • Changes made to the Delete Protocol are not retroactively applied to data already in SDMS.
    • If the Delete Protocol settings are incorrect, make the corrections to the template, save the template, and restart the Archive Agent. Re-archive the data into SDMS. The data becomes a candidate for deletion per the corrected Delete Protocol in the template.

ADDITIONAL INFORMATION

 

id72360, SDMS, SDMS8, SDMS8NU, SUPISDMS, SUPNG

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