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Waters

The NuGenesis RPC service is running, but NGD files do not move out of TE TEMP - WKB66330

Article number: 66330

SYMPTOMS

  • NGD files exist in the NuGenesis TE_TEMP folder, but the files are not processed
  • The NuGenesis RPC service is running
  • In the Windows Task Manager, The NGRPCService.exe process is running, but there are no NGRPCShadowServer.exe processes in the list
  • Transport Engine will not start

ENVIRONMENT

  • NuGenesis 9 SDMS
  • NuGenesis 8 SDMS

CAUSE

An empty "TETime.ini" file exists in the Temp folder for the NuGenesis RPC service user; or, a file named "%APPDATA%" exists in the C: drive.

FIX or WORKAROUND

  • 0-byte NGTETime.ini file:
    1. Look for the TETime file in the Temp folder for the NuGenesis RPC service account. The temp folder is typically C:\Windows\Temp or C:\Temp. If the service runs with a named user account (either a local or a domain account), the INI file will be in C:\Users\username\AppData\Local\Temp
    2. Delete the TETime file:
      • NuGenesis 9: NGTETime.ini
      • NuGenesis 8: NG80TETime.ini
    3. Restart the NuGenesis RPC service
    4. Defect CRI-611 was filed for this issue.  It was resolved in NuGenesis 9.0.2, but only if the the SDMS software was installed new; the 9.0.2 update program did not include the fix for defect CRI-611.  This fix is available separately from Waters as a software patch for systems which were upgraded to 9.0.2.  Contact Waters Technical Support or your field service engineer for assistance in obtaining this patch
  • Files in the C:\ drive:
    1. Look for files named %APPDATA% in the C:\ folder.  Make sure that hidden and system files are visible in Windows Explorer
    2. Delete these files if found

ADDITIONAL INFORMATION

The NuGenesis RPC service will enter this state if the file exists but is 0 bytes in size. If the file does not exist, the service builds a new TETime file. Defect report CRI-611 was filed for this issue.

Also rebooting database server has been known to resolve this issue in some cases.

A further observation was where a customer had created a TEMP folder on the D:Drive, the file originally could not be found on the C:Temp folder structures, but further digging meant we found another TEMP file on a separate drive. It is good practise to check other drives if it isn't immediately resolved using the directories mentioned above.

id66330, SDMS, SDMS8, SDMS8NU, SUPISDMS, SUPNG

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