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Waters

Error occurs when viewing the PDF report for an approved document in NuGenesis LMS - WKB66220

Article number: 66220

SYMPTOMS

  • The following error occurs when trying to view the PDF report for some approved documents in NuGenesis LMS:
    • An error occurred trying to generate PDF report.
    • One or more errors occurred.
  • The following message appears in the product.log file for the LMS client:
    • ERROR MainApp.Document.DocumentEditor [(null)] - User: userID, Method: createReport, Message: One or more errors occurred.

ENVIRONMENT

  • NuGenesis 9 LMS
  • NuGenesis 8 LMS
  • NuGenesis 8 ELN

CAUSE

An error occurred in the LMS Web server at the time the document was approved, which prevented the server from generating the PDF report.

FIX or WORKAROUND

  1. Look for the approval date in the document metadata.
  2. Examine the NuGenesis LMS Web server's log file (typically in C:\Temp\WATERSLMS\WLMSServer\WLMSIIS.log) for errors that occurred at the time of the document's approval.
  3. To fix specific documents, reopen the document for modification, and then have the appropriate user or users release, sign, and approve the document. The PDF report will be generated and stored in the database at the approval stage.

ADDITIONAL INFORMATION

An SQL script is available that can report on all documents that are approved in LMS but have no PDF report. Contact Waters Technical Support if you want to run this script.

id66220, ELN, NGLMS, NGLMSLIC, NGLMSOPT, SUPNG

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