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Cannot start the NuGenesis SDMS Instrument Agents as a service - WKB65584

Article number: 65584

SYMPTOMS

  • The NuGenesis SDMS Instrument Agents service does not start
  • The instrument agents run without error while running in a session outside the service
  • The following error message is seen in Drive:\Program Files\Waters\SDMSInstrumentAgents\agents\bin\windows\wrapper.log:
    • FATAL  | wrapper  | DATE TIME | A signature was found in "D:\Program Files (x86)\Waters\SDMSInstrumentAgents\agents\bin\windows\wrapper.exe", but checksum failed: (Errorcode: 0x468ec0)
    • FATAL  | wrapper  | DATE TIME | The Wrapper will shutdown!
  • When viewing the Digital Signatures tab of the properties page for wrapper.exe, Windows reports "The certificate in the signature cannot be verified"
  • When viewing the certificate for the digital signature (via the wrapper.exe properties page), the following messages appear:
    • General tab: "Windows does not have enough information to verify this certificate."
    • Certification Path tab: "The issuer of this certificate could not be found."

ENVIRONMENT

  • NuGenesis 9 SDMS
  • NuGenesis 8 SDMS

CAUSE

The server where the SDMS Instrument Agents are installed does not have access to the Internet. Windows requires access to the Internet in order to verify the digital signature and certificate for the wrapper.exe file.

FIX or WORKAROUND

Allow the SDMS Instrument Agent server(s) to connect to ocsp.comodoca.com if you plan to run them as a service.

ADDITIONAL INFORMATION

The wrapper.exe program is from Tanuki Software Ltd. The version that ships with the SDMS Instrument Agents is out-of-date and has an expired certificate for its digital signature. Enhancement CRI-722 was filed to request that the latest version of the Tanuki software be incorporated into Instrument Agents.

Windows will cache the results from the OCSP certificate check on the machine; however, the lifetime of the cached files is not known, so Windows may need to connect to the Internet for another OCSP check even if the cached files exist. It is recommended that you allow the SDMS Instrument Agent server(s) to access ocsp.comodoca.com on an ongoing basis rather than a one-time access.

id65584, SDMS, SDMS8, SDMS8NU, SUPISDMS, SUPNG

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