Skip to main content
Waters

Users are unable to log in to NuGenesis LMS with LDAP credentials - WKB65472

Article number: 65472

SYMPTOMS

  • Users of NuGenesis LMS are unable to log in to the system
  • Users who repeatedly try to log in have their accounts locked out of LMS
  • The following error message appears in the LMS server's server.log file:
    • ERROR [com.creon.common.secure.LDAPAuthentificator] (http-0.0.0.0-8180-10) Problem accessing LDAP Server, e.g user not available in LDAP: javax.naming.CommunicationException: LDAPServerName:636 [Root exception is java.net.ConnectException: Connection timed out: connect]

ENVIRONMENT

  • NuGenesis 9 LMS
  • NuGenesis 8 LMS
  • LMS is configured for LDAP authentication

CAUSE

The LMS server is unable to connect to either the primary or secondary LDAP servers.

FIX or WORKAROUND

  1. Ensure that the LDAP servers are online.
  2. Log on to the LMS server's desktop and use the nslookup tool to confirm the IP address that LMS receives for the LDAP servers' domain names. Compare these IP addresses with the known IPs for the LDAP servers.
    • If the IP addresses are incorrect, the LMS server is getting a bad IP from DNS.
    • If the IP addresses are correct but LMS still cannot connect to LDAP, the LDAP servers are likely offline.
  3. Most solutions require action and feedback from the network and/or LDAP administrators, so work with the appropriate people to resolve any server availability or name resolution issues.

ADDITIONAL INFORMATION

 

id65472, comms, ELN, NGLMS, NGLMSLIC, NGLMSOPT, SUPNG

Not able to find a solution? Click here to request help.