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Error: "[NG24035] Server X is not valid" appears when logging in to NuGenesis WebVision - WKB6119

Article number: 6119

SYMPTOMS

  • The following error message appears when logging in to WebVision:

    • "[NG24035] Server X is not valid." (where "X" is the name of a server in the SDMS database's Master List)

ENVIRONMENT

  • NuGenesis 9 SDMS
  • NuGenesis 8 SDMS

CAUSE

The server name is not in the tnsnames.ora file on the SDMS web server.

FIX or WORKAROUND

  1. Edit the tnsnames.ora file in the SDMS Web Server's Oracle client in Notepad.
    • NuGenesis 8: Drive:\Program Files (x86)\NuGenesis 8.0\SDMS11gOracleClient\tnsnames.ora
    • NuGenesis 9: Drive:\Program Files (x86)\Waters\NGSDMS\SDMS12cOracleClient\tnsnames.ora
  2. Ensure that the server name is listed as the "alias" for a connection, as follows:
  3. server.WORLD =
      (DESCRIPTION = ...
  4. In the example, the alias is "server", and it must match the server name given in the error message.
  5. Save and close the tnsnames.ora file.

ADDITIONAL INFORMATION

See below for the full connection information as copied from a tnsnames.ora file:

win2012-64-mm6.WORLD =
  (DESCRIPTION =
    (ADDRESS_LIST =
      (ADDRESS = (PROTOCOL = TCP)(HOST = win2012-64-mm6)(PORT = 1521))
    )
    (CONNECT_DATA =
      (SERVICE_NAME = sdms)
    )
  )

Error occurs if a server is removed/deleted from NuGenesis System Administrator.

NuGenesis Vision Recently viewed Server list has a server on the list that is not in NuGenesis System Administrator.

Corrective action: Add the server back in NuGenesis System Administrator.

Open NuGenesis Vision (all NuGenesis Web Servers) and log in to the server that will not be removed.

Under the Tools tab, click on clear recently viewed. 

Log out. 

Log in to NuGenesis System Administrator, remove the server, and update the local list.

id6119, SDMS, SDMS8, SDMS8NU, SUPISDMS, SUPNG

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