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Unable to view a PDF report in NuGenesis LMS - WKB60896

Article number: 60896

SYMPTOMS

  • When a user tries to view a PDF report for a non-approved document in LMS, an error message appears, with the following text visible after pressing the "Show Details" button:
    • Operation not supported on selected printer stacktrace:
         at VSPDFViewerX.VSPDFPrinterClass.set_printOrientation(TxVSPDFPrintOrientation Value)
         at Creon.PDFViewer.PDFViewer..ctor()
         at Creon.DRAGON.DRG0022.Page.PDFForm.InitializeComponent()
         at Creon.DRAGON.DRG0022.Page.PDFForm..ctor()
         at MainApp.Document.DocumentEditor.showReport(Byte[] pdf, Boolean isSafeSign)
         at MainApp.Document.DocumentEditor.miViewPDFReport_Click(Object sender, RoutedEventArgs e)
  • Other users can view the PDF report for the same document

ENVIRONMENT

  • NuGenesis 9 LMS
  • NuGenesis 8 LMS
  • NuGenesis 8 ELN
  • Citrix XenApp

CAUSE

The user's default printer is set to a printer from an inactive session; or, the user's default printer is offline.

FIX or WORKAROUND

Ensure that the default printer for each user's session is set to a valid printer from the user's client machine. This can be set through the management tools on the Citrix XenApp server.

ADDITIONAL INFORMATION

LMS uses the paper size of the default printer in the user's session in order to set the page size of the PDF report.

id60896, ELN, NGLMS, NGLMSLIC, NGLMSOPT, SUPNG

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