Skip to main content
Waters

Cannot configure a NuGenesis SDMS archive template for Empower 3 projects - WKB50944

Article number: 50944

SYMPTOMS

  • When selecting "Waters Corp. Empower-3 Projects 0" in the SDMS Archive Template Builder, no error messages appear, but some information is missing:
    • The Language drop-down list contains only "N/A"
    • The Empower-specific metadata tags do not appear in the Metadata Mapping list
  • The Empower server list does not appear in the drop-down list on the Advanced tab of the template
  • The template builder appears to hang, or becomes unresponsive, when loading the project exceptions list

ENVIRONMENT

  • NuGenesis 8 SDMS
  • Empower 2
  • Empower 3

CAUSE

The Empower Toolkit DLLs are not registered on the remote machine.

FIX or WORKAROUND

  1. Run the following commands on the Empower machine in a Command Prompt with admin rights (assuming the default install path for the Empower client):
    1. C:\Windows\syswow64\regsvr32.exe C:\Empower\Bin\MillServices.dll
    2. C:\Windows\syswow64\regsvr32.exe C:\Empower\Bin\MilTk.dll
  2. In the SDMS Archive Template Builder, reselect the VPR. The template builder will reconnect to the Remote half of the data adapter and it should now populate the language list, the metadata tags, and the server list.

ADDITIONAL INFORMATION

 

Not able to find a solution? Click here to request help.