Skip to main content
Waters

Error "No Action Available" when editing an MS Office document section in NuGenesis LMS and Office is installed - WKB49249

Article number: 49249

SYMPTOMS

  • The following error messages appear when opening an Excel, Word, or PowerPoint document section for viewing or editing in NuGenesis LMS:
    • "No Action Available"
    • "The selected version cannot be opened. Probably it is an un-editable picture or the default editor is not available."
  • The Microsoft Office suite is installed on the LMS client machine
  • The section is not opened

ENVIRONMENT

  • NuGenesis 9 LMS
  • NuGenesis 8 LMS
  • NuGenesis 8 ELN
  • 32-bit Microsoft Office 2007, 2010, 2013, or 2016

CAUSE

The Microsoft Office application returned invalid data to LMS when the section was closed. The Office application cannot reopen the data that it sent to LMS.

FIX or WORKAROUND

To limit the chances of this error recurring:

  1. Ensure that all of the service packs, patches, and hotfixes for the installed version of Microsoft Office are installed.
  2. Disable the following setting in Excel, Word, and PowerPoint on all LMS clients:
    • File > Options > Trust Center > Trust Center Settings > Privacy Options: Remove personal information from file properties on save

To recover or rebuild the section:

  1. Delete the section and add a new copy, either from a section template or from a file dropped in from outside LMS, depending on how the original section was created in LMS.
  2. If the data in the corrupted section must be recovered, contact Waters Technical Support for assistance.

ADDITIONAL INFORMATION

This issue is seen most often with Office documents that incorporate non-text data, numerous large images or charts, or very large sections, such as Excel sheets with more than 1000 visible rows.

id49249, ELN, NGLMS, NGLMSLIC, NGLMSOPT, SUPNG

Not able to find a solution? Click here to request help.