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Error "LMS server is not available" when logging in to the NuGenesis LMS client - WKB48402

Article number: 48402

SYMPTOMS

  • The following error message appears when logging in to NuGenesis LMS:
    • "LMS server is not available"

ENVIRONMENT

  • NuGenesis 9 LMS
  • NuGenesis 8 LMS
  • NuGenesis 8 ELN

CAUSE

  • The Oracle database for NuGenesis LMS is stopped
  • The NuGenesis LMS Server service is stopped
  • The client machine cannot resolve the LMS server's hostname or fully qualified domain name

If all of the LMS users get this message, the problem likely is in the Oracle or LMS servers; if it affects only one or a few users, it's likely a problem with their client machines.

FIX or WORKAROUND

  1. Ensure that the Oracle database is online and open.
    1. Review the alert logs for the NuGenesis LMS/SDMS instance for any recent errors that would prevent the instance from starting.
    2. For Oracle databases on Windows, ensure that the services "OracleServiceSDMS" and OracleSDMSTNSListener" are both started and set for automatic startup.
  2. Start or restart the NuGenesis LMS Server service:
    1. Remote over to the LMS server machine and ensure that the "NuGenesis LMS Server" service is started and set for automatic startup.
    2. The service could start and remain running while in an error state; for this reason, review the log file in Drive:\WatersLMSServer\log\server.log for recent errors.
  3. Determine if the client machine can resolve the server's hostname or qualified domain name:
    1. Remote over to the LMS server and run the "NuGenesis LMS IIS Configuration" tool from the Desktop or the Start screen.
    2. Click Next in the configuration tool.
    3. Record the entries in the Server Host column of the table. The first entry is usually the same server machine and entries 1 and 2 are usually alternate LMS servers/environments and may not be present in the table.
    4. Open a command prompt and run the ipconfig tool to get the server's IP address.
    5. On the client machine, open a command prompt and use the ping.exe tool to ping the LMS server's hostname and fully qualified name.
      1. If the IP address returned by the ping tool is not the same as the one seen in the ipconfig tool's output, it's likely that the DNS resolver is returning the wrong IP address for the name, or there is an entry in the localhosts file that has the wrong IP for the name.
      2. Repeat this test on other clients in different subnets.
      3. Edit the LMS IIS Configuration to use either the hostname or the fully qualified domain name, whichever name is more widely resolvable among the client machines.
  4. Ensure that the Windows Firewall on the NuGenesis LMS server allows inbound traffic to port 8180.
    • If the LMS clients still cannot connect to the server, speak with the network administrator for any network-level firewall that may prohibit connections between the client machines and the server.
  5. Ensure that there are no invalid font references in module.xml
    • On the LMS server, browse to '<Drive>:\WatersLMSServer\Wildfly-11.0.0.Final\modules\system\layers\base\waters\lms\reports\main' (path different in v8) and open the module.xml file.  Ensure that all referenced font files are valid.  Remove or comment out any lines corresponding to font files that do not exist and then restart the NuGenesis LMS Server Service.

ADDITIONAL INFORMATION

 

id48402, ELN, NGLMS, NGLMSLIC, NGLMSOPT, SUPNG

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