Skip to main content
Waters

Error "NG24034 Server Group is not valid" occurs when loading WebVision - WKB3275

Article number: 3275

SYMPTOMS

  • The error message "Server Group is not valid" appears when loading SDMS WebVision

ENVIRONMENT

  • NuGenesis 9 SDMS
  • NuGenesis 8 SDMS

CAUSE

The TNS Service Name entered in the System DSNs is incorrect; it doesn't match an entry in the tnsnames.ora file. Or, the Oracle Database is down.

FIX or WORKAROUND

  1. Log in to the SDMS Web server.
  2. Open the ODBC Administrator window:
    • Start > All Programs > Waters Oracle Client > Configuration Tools > Microsoft ODBC Administrator
  3. Select the System DSNs tab.
  4. Select one of the SDMS DSNs:
    • _NG_PROJ80_ORACLEINFO_
    • _NG_PROJLIST_MASTER80_
  5. Click the Configure button.
  6. Confirm that the TNS Service Name entry is correct. Validate it against the list of aliases given in the TNS names configuration tool:
    • Start > All Programs > Waters Oracle Client > Configuration Tools > Waters Net Configuration Assistant
  7. Click in to the TNS Service Name box and look for any extra spaces before or after the name. Delete any blank spaces found.
  8. If any changes are made, click the Test Connection button to confirm that the connection is OK.  Supply an Oracle username and password when prompted.
  9. Click OK to save and close the DSN properties.
  10. Repeat steps 5 through 9 for the other SDMS DSN.
  11. Log in to SDMS WebVision and confirm whether the error message still occurs.

ADDITIONAL INFORMATION

The SDMS Web server uses the system-defined Data Source Names (DSNs) to make the initial connections to the SDMS database when loading WebVision. It checks with the database in order to query for the Master List of database servers that are available to the user. If anything goes wrong with that process—such as a TNS Service Name that is not in the tnsnames.ora file, or a database that is unavailable—users will see the "Server Group is not valid" message.

Note that the "Server Group" message is different than the similarly worded "Server <name> is not valid" message. This article covers the "Server Group" case. For the other case, please consult the article Error "Server 'name' is not valid" occurs when loading WebVision.

For intermittent 'Server Group not Valid' errors.  Also ensure that the IP address of each NuGenesis Server and/or client is unique on the network.

id3275, SDMS, SDMS8, SDMS8NU, SUPISDMS, SUPNG

Not able to find a solution? Click here to request help.