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Java Heap Space tuning in NuGenesis LMS - WKB3269

Article number: 3269

SYMPTOMS

  • Users may receive an error message when opening a document through the NuGenesis LMS client.
  • The error message, recorded in the LMS client's log files, says (in part) "Caused by: java.lang.OutOfMemoryError: Java heap space".
  • The error is more likely to occur with larger documents (documents with many large and high-resolution images, or many document sections).

ENVIRONMENT

  • NuGenesis 9 LMS
  • NuGenesis 8 LMS
  • NuGenesis 8 ELN

CAUSE

The Java runtime environment is not able to allocate enough memory to the LMS server in order for the server to service a user request (such as opening a document).

FIX or WORKAROUND

  1. Open the file Drive:\WatersLMSServer\javaServiceWrapper\conf\wrapper-jboss.conf in Notepad.
  2. Look for the following lines:
    • # Maximum Java Heap Size (in MB).
    • wrapper.java.maxmemory=
  3. The default value for wrapper.java.maxmemory is 1024. Change that number to another number, equivalent to a number in GB (ex: 4096 for 4 GB).
  4. Save and close the file.
  5. Restart the NuGenesis LMS Server service.

ADDITIONAL INFORMATION

The NuGenesis LMS Server is a 64-bit application that runs in a Java runtime environment. The JRE allocates memory from the system per its initialization parameters, which it then makes available to the Java applications that run within the environment (in the case of an LMS server, there is only one Java application: the LMS Server service). It is recommended that you raise the JRE's heap allocation limit to 4 GB for all installations, and that you raise it further if 4 GB proves to be insufficient for the server load. All user actions in LMS incur some memory use, memory which is released when it is no longer needed, but some actions may require larger allocations of memory.

The LMS client's log file is stored in the AppData folder within the user profile folder. If the LMS client runs locally on a user's PC, then the AppData folder (and the LMS log file are stored locally on the PC; if LMS runs through a Citrix client, then the log file is in the user's profile folder on the Citrix server. Additional complications in finding the log file can arise if there are many Citrix servers in a farm (and users are redirected to different servers within the farm), or if Citrix profile management is in use. Profile management takes many forms, but most commonly, they store user profiles on a central server, not on any individual Citrix server. For the case where LMS runs on a local PC, the log file is found by specifying the following paths in the Start > Run prompt on the PC while logged in to the PC as a specific user:

  • NuGenesis 8 LMS: %AppData%\Waters\NuGenesis LMS\version\Product.log
  • NuGenesis 8 ELN: %AppData%\Waters\NuGenesis ELN\version\Product.log

id3269, ELN, NGLMS, NGLMSLIC, NGLMSOPT, SUPNG

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