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Error "Access to the path 'Drive:\Temp\WATERSLMS' is denied" when generating a PDF report from a NuGenesis LMS document - WKB261579

Article number: 261579

SYMPTOMS

  • The following error message appears for all users when opening any document report in LMS:
    • Access to the path '<Drive>:\Temp\WATERSLMS' is denied
  • The same message appears in the LMS client's log file
  • The stated path does not exist on the LMS client

ENVIRONMENT

  • NuGenesis 9 LMS
  • NuGenesis 8 LMS

CAUSE

The file path stated in the error message is on the LMS server, not the clients. The "ApplicationPoolId" for LMSApplicationPool within IIS does not have Write access to the stated file path.

FIX or WORKAROUND

  1. Open IIS Manager on the NuGenesis LMS server.
  2. Click on application Pools.
  3. Select "LMSApplicationPool" and click Advanced Settings.
  4. Look for "Identity" in the list of settings. This is often set to "ApplicationPoolIdentity".
  5. Double-click this setting and set it to a known user account with read/write privileges on the Temp\WATERSLMS path.
  6. Click OK.
  7. Restart the application pool.

ADDITIONAL INFORMATION

 

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