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The NuGenesis SDMS Data Management Module does not start on new installation of SDMS 9.x File Capture components - WKB258674

Article number: 258674

SYMPTOMS

  • The Data Management Module does not start in the NuGenesis Service Configuration Console (SCC)
  • The Auto IQ log file for the SDMS File Capture components is clean; no errors or warnings

ENVIRONMENT

  • NuGenesis SDMS 9

CAUSE

One or more DLL files were not registered at the time of installation.

These files are specific to SDMS File Capture Component: NgArMSLObs.dll; NGSDKObjects.dll; NGDMCore.dll; NGRestoreCore.dll; and NGArchiveAgentDll.dll

FIX or WORKAROUND

  1. Stop the NuGenesis RPC service.
  2. Register the DLLs in a command prompt with Admin rights:
    • C:\Windows\syswow64\REGSVR32.exe "C:\Windows\SysWOW64\NGarmslobs.dll"
    • C:\Windows\syswow64\REGSVR32.exe "C:\Windows\SysWOW64\NGSDKObjects.dll"
    • C:\Windows\syswow64\REGSVR32.exe "C:\Windows\SysWOW64\NGRestoreCtrl.ocx"
    • regasm.exe "Drive:\Program Files (x86)\Waters\NGSDMS\Common Files\NGDMCore.dll" /codebase /verbose
    • regasm.exe "Drive:\Program Files (x86)\Waters\NGSDMS\Common Files\NGArchiveAgentDll.dll" /codebase /verbose
  3. Restart the NuGenesis RPC service.
  4. Log in to the SCC to check whether the Data Management Module will start.

ADDITIONAL INFORMATION

Some are c++ assemblies (registered using regsrv32.exe) and others are .NET assemblies (registered using regasm.exe).

Use the regsvr32 from C:\Windows\SysWow64; first navigate to that folder in command prompt (Run as Administrator).

id258674, SDMS, SDMS8, SDMS8NU, SUPISDMS, SUPNG

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