Skip to main content
Waters

Error "The database instance must be version 19.0.0.0 or greater" appears when installing the Oracle database for NuGenesis 9.3 - WKB251598

Article number: 251598

SYMPTOMS

  • The following error message appears when installing the Oracle database for NuGenesis 9.3 on Windows servers:
    • The database instance must be version 19.0.0.0 or greater
  • The database is not installed

ENVIRONMENT

  • NuGenesis 9.3
  • Windows server 2016/2019
  • NuGenesis 9.3.0 installation ISO file, part number 667003931, Rev A

CAUSE

  • A password policy is set on the machine that requires nine or more characters in the passwords for local accounts

FIX or WORKAROUND

  1. Use the NuGenesis 9.3.0 667006931 Rev B ISO file to install the database.  This version of the setup process allows the user to enter a password for WATOracle
  2. Password policy:
    • One option is to remove the machine from the domain, allowing local control over the password policy. Set the password policy to a minimum of eight characters, and then rerun the NuGenesis database setup.
    • Another option is to move the machine into a different domain, one with a different (and more lenient) password policy.
    • Third, it is possible to install the NuGenesis 9.1 database on the machine, and then use the Upgrade function in the 9.3 media to upgrade the schemas to 9.3.
  3. Rerun the Oracle database installer.
  4. Confirm that the WATOracle local account has been created, or create it with a suitable password if not present. Ensure that it has the "Logon as a batch job" and "Log on as a service" rights and is in the following local groups:
    • ORA_INSTALL
    • ORA_NuGenesis_DBA
  5. Grant WATOracle full rights on the Oracle flash recovery area:
    • Drive:\oracle\product\19c\fast_recovery_area
  6. Grant WATOracle full rights on the Oracle wallet folder:
    • Drive:\oracle\product\19c\admin\NG93\wallet\tde
  7. After installation of the Waters Database Manager, log in to WDM, click Administration > Application Configuration, and set the correct password for WATOracle in “OS JOB PASSWORD”.

ADDITIONAL INFORMATION

Fine-grained password policies do not help with this scenario because they apply only to user accounts in a domain, not to machine accounts.

id251598, SUPNG

Not able to find a solution? Click here to request help.