Skip to main content
Waters

HTTP 502 occurs when clicking the "View audit trail" link in NuGenesis WebVision - WKB198295

Article number: 198295

SYMPTOMS

  • HTTP 502 error occurs after clicking View Audit Trail for one or more reports in NuGenesis WebVision
  • The error occurs several minutes after clicking the View Audit Trail link

ENVIRONMENT

  • NuGenesis 9 SDMS
  • NuGenesis 8 SDMS
  • Several million rows are present in the NuGenesis SDMS audit trail tables

CAUSE

Oracle uses a full-table scan on the SDMS audit trail tables when running the query. For databases with more than 5 million rows in the audit trail tables, this query can exceed the timeout period on the HTTPS connection, resulting in an HTTP 502 error in the browser.

FIX or WORKAROUND

  1. Verify the number of rows that exist in the Audit Trail Table. In SQLPLUS, issue the following command and send the result to support 
    SELECT COUNT(*) FROM ngsysuser.ngauditmaster.
  2. A new index on the SDMS Audit Trail tables can resolve this issue. Contact Waters Technical Support for assistance in implementing this index.

ADDITIONAL INFORMATION

Enhancement request CRI-2875 was filed so that the new index can be incorporated into the next release of NuGenesis.

id198295, SDMS, SDMS8, SDMS8NU, SUPISDMS, SUPNG

Not able to find a solution? Click here to request help.