HTTP 502 occurs when clicking the "View audit trail" link in NuGenesis WebVision - WKB198295
Article number: 198295
SYMPTOMS
- HTTP 502 error occurs after clicking View Audit Trail for one or more reports in NuGenesis WebVision
- The error occurs several minutes after clicking the View Audit Trail link
ENVIRONMENT
- NuGenesis 9 SDMS versions 9.0.x through 9.2
- The index mentioned in the Fix or Workaround section was incorporated into the base installation starting with NuGenesis 9.3
- Several million rows are present in the NuGenesis SDMS audit trail tables
CAUSE
Oracle uses a full-table scan on the SDMS audit trail tables when running the query. For databases with more than 5 million rows in the audit trail tables, this query can exceed the timeout period on the HTTPS connection, resulting in an HTTP 502 error in the browser.
FIX or WORKAROUND
- Verify the number of rows that exist in the Audit Trail Table. In SQLPLUS, issue the following command and send the result to support
SELECT COUNT(*) FROM ngsysuser.ngauditmaster. - A new index on the SDMS Audit Trail tables can resolve this issue. Contact Waters Technical Support for assistance in implementing this index.
ADDITIONAL INFORMATION
Enhancement request CRI-2875 was filed so that the new index can be incorporated into the next release of NuGenesis.
