Error "[NG14647] Failed to connect to the server" appears when using the NuGenesis Transfer App - WKB19784
Article number: 19784
SYMPTOMS
- The following error message is displayed by the Transfer Application when opening a report or downloading file data from NuGenesis:
- "[NG14647] Failed to connect to the server."
ENVIRONMENT
- NuGenesis 8 SDMS
- NuGenesis 9 SDMS
CAUSE
The user's machine cannot connect to the NuGenesis RPC service on the NuGenesis SDMS server.
FIX or WORKAROUND
- Ensure that the NuGenesis RPC service is started on the server.
- Either turn off or allow traffic on TCP ports 2500-2504 through the firewall on the NuGenesis server.
- The Transfer App uses a setting in a WebVision config file on the NuGenesis web server as the host and port number for the NuGenesis RPC service
- NuGenesis 8 and 9 (legacy WebVision):
- NuGenesis 8: Drive:\Program Files (x86)\apache-tomcat-6.0.29\webapps\WebVision\ngvision\WebVision.ini
- NuGenesis 9: Drive:\Program Files (x86)\Waters\apache-tomcat-9.0.8\webapps\WebVision\ngvision\WebVision.ini
- The RPC service's host name and port number are given as two right-most parameters for the "local" entry in the servers list within WebVision.ini
- Example: local='localhost,1,12020,...,'NuGenesis RPC Service V8.0','NG8ProdServer',2500 (NuGenesis 8 SDMS)
- Example: local='localhost,1,12020,...,'NuGenesis RPC Service','NG8ProdServer',2500 (NuGenesis 9 SDMS)
- NuGenesis 9 (new WebVision)
- Drive:\Program Files (x86)\Waters\NGSDMS\Application Server\Vision\SdmsProjects\appsettings.json
- The NuGenesis RPC service's hostname and port re given in the "RpcService" block within the file
- If changes are made to the WebVision config file(s), then open IIS Manager and restart Default Web Site for legacy WebVision and SdmsProjects for new WebVision
- NuGenesis 8 and 9 (legacy WebVision):
- Ensure that the client machines can resolve the RPC service's hostname:
- Add an entry to the hosts file on the client machines that maps the RPC service name to the server's IP address.
- Or, change the entry in WebVision.ini to use a fully qualified domain name.
- Or, work with the local IT professionals to ensure that authoritative DNS server's A record for the hostname has the correct IP address for the NuGenesis server.
- On the client machines, use the Ping and NSLookup tools to test the connection to the NuGenesis server.
ADDITIONAL INFORMATION
With NuGenesis 9 SDMS, a message box stating "The password you used to log in will expire in <nnnnnn> days. Would you like to change it now?" may appear before the "[NG14647] Failed to connect to the server" message.
id19784, SDMS, SDMS8, SDMS8NU, SUPISDMS, SUPNG