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Waters

Cannot log in to the NuGenesis LMS-SDMS Interface Wizard - WKB18325

Article number: 18325

SYMPTOMS

  • The following error message appears when logging in to the SDMS Extract Results Wizard:
    • "Login to LMS Failed: Please check connectstring and credentials."

ENVIRONMENT

  • NuGenesis 9 LMS
  • NuGenesis 8 LMS
  • NuGenesis 8 ELN

CAUSE

  • Invalid login credentials or connect URL in the SDMS2ELN.ini file
  • The LMS-SDMS Interface is not at the same version as the LMS SDK

FIX or WORKAROUND

  1. Run the Auto IQ programs for the LMS SDK and LMS-SDMS Interface.
  2. Compare the minor version numbers in the IQ log files.
    • Working example: "NuGenesis LMS SDK 9.0.2 Service Release" and "NuGenesis LMS SDMS Interface V2.0.2"
    • Non-working example: "NuGenesis LMS SDK 9.0.2 Service Release" and "NuGenesis LMS SDMS Interface V2.0"
  3. If the minor versions do not match, install the correct version of the LMS-SDMS Interface from the installation media.
  4. Configuration:
    1. Stop the NuGenesis LMS SDMS Interface service.
    2. Edit the file SDMS2ELN.ini in C:\ProgramData\Waters\Sdms Result Extractor.
    3. Set the ELNUser and ELNPasswd to a valid LMS username and password.
    4. Confirm that the ELNConnect string has the correct hostname or fully-qualified name for the LMS server, the port number 8180, and "/vp/services/".
    5. Save and close the file.
    6. Start the service.
  5. Confirm that the NuGenesis LMS Server service is started on the LMS server; confirm that users can log in to LMS.

ADDITIONAL INFORMATION

The following message appears in the service's log file if it is configured with the SYSTEM account when LMS is configured for LDAP authentication:

"DATE TIME,942 [6] ERROR Waters.ELN.ToolKit.SessionContext [(null)] - logon failed with reason 4"

id18325, NGLMS, NGLMSLIC, NGLMSOPT, SUPNG

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