Reports not printed from Empower 3 after result signoff to NuGenesis UNIFY - WKB15794
SYMPTOMS
- No report appears in NuGenesis WebVision after signing off on a result in Empower.
- Clicking OK in the SDMS Archive Properties window results in a crash of the Empower Configuration Manager program.
ENVIRONMENT
- Empower 3 is configured to print a report to NuGenesis UNIFY after signature
CAUSE
- The NuGenesis UNIFY proxy process is not running under the same account as the UNIFY print job owner
- User preferences in Empower are invalid for the user
FIX or WORKAROUND
- If the WatersService is not required on the machine, then stop the service, which will shift the processing of print-on-signoff jobs to empower.exe. The Empower client process typically runs in the user's logon session and with the user's logon ID, whereas WatersService runs as a service account (LocalSystem, Local Service, Network Service, or a named account in the domain) which is distinct from the user logon accounts
- Check for and start the UNIFY Proxy process under the correct user account:
- Open the printer queue for UNIFY and take note of the Owner column for the stuck print jobs
- Start the Windows task manager and look for the proxy process:
- NuGenesis 9: NGprox.exe
- NuGenesis 8: NG80prox.exe
- If there is no proxy process running under the same account as the owner of the stuck jobs, then the jobs will not be completely processed
- Use the command-line tool "runas" to start the UNIFY proxy process under the correct account
- Example for NuGenesis 9: runas.exe /user:domain\serviceUser "Drive:\Program Files (x86)\Waters\NGSDMS\UV\NGprox.exe"
- Clear the stuck jobs from the UNIFY printer queue
- If the UNIFY proxy process is running under the correct account and the jobs still are not processed:
- Log in to Empower with Administrator rights and open Configuration Manager.
- Click the View menu > Copy Preferences.
- Set the Source User to System.
- Select any project for the Source Project.
- Select the appropriate user names in the Copy To Users list.
- Click the Select All button under the Projects list, so that the preferences are copied to all projects.
- Click OK to start the Copy process. This process may take a long time to complete if many projects are selected.
ADDITIONAL INFORMATION
See also: How to install and configure the Print on Signoff to NuGenesis option in Empower
Defect report CRI-2175 was filed for this issue.
The "SDMS Login" component of NuGenesis SDMS - available on the NuGenesis LMS Base Kit ISO file - was intended to solve the problem created by UNIFY print jobs from system services; however, starting in NuGenesis 8 Feature Release 1, this component does not start the ngprox process, as it did in earlier versions.
The WatersService must be running on machines which act as LAC/E boxes or which control instruments. In this case, the best option is to use the RunAs.exe tool to start NGProx with the same logon ID as the service. For analysis-only machines, the WatersService can be turned off, which is the preferred workaround.
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