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Error in NuGenesis LMS: "Error occurred trying to generate PDF report" - WKB15127

Article number: 15127

SYMPTOMS

  • The following error occurs when opening a PDF report in NuGenesis LMS:
    • "Error occurred trying to generate PDF report.
      The maximum message size quota for incoming messages 268435456 has been exceeded.
      To increase the quota, use the MaxReceivedMessageSize property on the appropriate binding element"

ENVIRONMENT

  • NuGenesis 9 LMS
  • NuGenesis 8 LMS 
  • NuGenesis 8 ELN

CAUSE

The maximum message size quota for incoming messages (268435456) has been exceeded.

FIX or WORKAROUND

  1. The ELN max message size is defined in two places: in the ELN web server (web.config) and in the ELN client (eln.exe.config)
  2. On the LMS web server:
    1. Open the file Drive:\inetpub\wwwroot\WATERSELN\web.config in a text editor
    2. Look for the following lines:

       <!--All the services use this maxrequestlength 256MB * 1024 * 1024-->
       <add key="maxRequestLength" value="268435456" />

      Modify/update the lines to the following: Increase to 512 MB

       <!--All the services use this maxrequestlength 512MB * 1024 * 1024-->
       <add key="maxRequestLength" value="536870912" />

      In the same file, modify the following lines:

       <services>
       <service name="Creon.Dragon.WebService.ExperimentReportService">
       <endpoint binding="basicHttpBinding" contract="Creon.Dragon.WebService.IExperimentReportService" />
       </service>
       </services>
       <behaviors>

      Update the lines to the following (note that you must add the lines <bindings> and </bindings> and everything in between):
       <services>
       <service name="Creon.Dragon.WebService.ExperimentReportService">
       <endpoint binding="basicHttpBinding" contract="Creon.Dragon.WebService.IExperimentReportService" bindingConfiguration="largerMessageSize" />
       </service>
       </services>
       <bindings>
                  <basicHttpBinding>
                              <binding name="largerMessageSize" maxReceivedMessageSize="536870912" />
                  </basicHttpBinding>
       </bindings>
       <behaviors>
    3. Save and close the file.
    4. Go to IIS Administration in Control Panel > Administrative Tools, Select Sites > Default Web Site, and click Restart under "Manage Web Site".
  3. On the ELN client:
    1. Open the file Drive:\Program Files (x86)\Waters\NuGenesis LMS\eln.exe.config, and look for the following line:
      • <add key="maxRequestLength" value="268435456"></add>
    2. Change that line to the following:
      • <add key="maxRequestLength" value="536870912"></add>
    3. Save and close the file.

ADDITIONAL INFORMATION

Increasing the limits for documents (images, sections etc...) will increase CPU and memory used since the information being transferred is larger. The end result causes the CPU and Memory usage to increase. This article fixes the issue for large documents but the end result CPU and Memory usage go up. Some systems/environments may require additional CPU memory or an addition of another LMS Web App Server and possible load balance environment.

Please be aware that incorrect edits to the Web.Config file can result in the Installations list being blank when trying to log into LMS.  Always make a copy of the Original Web.Config file prior to making any changes, in case you need to roll back as a result of Blank Installations list.

id15127, ELN, NGLMS, NGLMSLIC, NGLMSOPT, SUPNG

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