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Error "The install program could not install the NuGenesis UNIFY driver" appears when installing NuGenesis UNIFY - WKB117596

Article number: 117596

SYMPTOMS

  • The following error message appears when installing the NuGenesis UNIFY printer:
    • The install program could not install the NuGenesis UNIFY driver. Please restart the computer and start the setup program again. If the problem persists, please notify Technical Support.
    • [Error Code 0]
    • (No error message found)
  • The UNIFY setup program completes and requests a system restart
  • Three files fail the UNIFY Auto IQ check
  • The NuGenesis UNIFY printer is not in the Devices and Printers list

ENVIRONMENT

  • NuGenesis 9 SDMS
  • NuGenesis 8 SDMS

CAUSE

One or more system files are missing.

FIX or WORKAROUND

  1. Ensure that the Visual C++ Runtime distributions are installed on the machine. UNIFY in NuGenesis 8 and 9 requires the 64-bit Visual C++ Runtime 2015, 2017, or 2019 Redistributable packages, or the combination 2015/2017/2019 package. Use the x64 version of the redistributable for 64-bit machines and the x86 version for 32-bit machines.
  2. If the issue occurs during a UNIFY installation and all of the prerequisites are present, it's likely that one of the prerequisites is incompletely installed.
    1. Uninstall NuGenesis UNIFY.
    2. Uninstall all of the Visual C++ Runtime packages.
    3. Restart the machine.
    4. Run the UNIFY installation program. It checks for and installs the prerequisite packages as needed. Proceed with the UNIFY installation.

ADDITIONAL INFORMATION

The setup program writes a log file to disk, in C:\nginstall.log, which contains messages from the print driver installation process. If troubleshooting this issue and the VC++ Runtime package is already installed, search this file for the last instance of "ngdriverinstaller.exe".  The log file should list the exit code for this process. Copy this exit code and send it, along with the log file and a screenshot of the error message, to Waters technical support for analysis.

The error message and code typically look like this line (the error code is in Bold):

  • UNIFY Install Error: Bad exit code from "C:\Users\username\AppData\Local\Temp\{BB415~1\{437FB~1\ngdriverinstaller.exe" "C:\Users\username\AppData\Local\Temp\{BB415~1\{437FB~1" "NuGenesis UNIFY" "false".    Error = 3221225781.
    • Error 3221225781 translates to "STATUS_DLL_NOT_FOUND" / "Code execution cannot proceed because %hs was not found. Reinstalling the program may fix this problem."  This error code indicates that the UNIFY driver installer depends on a DLL that is not found in the system. Typically, the missing DLL is named in neither the error message nor the nginstall.log, but it is one of the DLLs provided by the Visual C++ Runtime packages.

id117596, SDMS, SDMS8, SDMS8NU, SUPISDMS, SUPNG

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