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NuGenesis Archive Agent, Data Management, and Transport Engine modules do not start - WKB11755

Article number: 11755

SYMPTOMS

  • NuGenesis Archive Agent (AA), Data Management (DM), and Transport Engine (TE) do not start in the Service Configuration Console

ENVIRONMENT

  • NuGenesis 9 SDMS
  • NuGenesis 8 SDMS

CAUSE

The NuGenesis user account assigned to the AA, DM, and TE modules is either an invalid or inactive NuGenesis account, or the user account does not have permissions to run those modules.

FIX or WORKAROUND

  1. Log in to the Service Configuration Console using a NuGenesis account that is valid and has permissions to run the modules.
    • The built-in "ngprojmgr" account can be used for this purpose.
  2. Select each module and click the Save button to write the NuGenesis account credentials into the module's configuration.
  3. Start each module.

ADDITIONAL INFORMATION

Running the SCC Manager with admin rights, via the right-click > Run as Administrator menu option, is recommended because user accounts in Windows 2012 by default run programs with limited rights. The SCC Manager program must check the status of the NuGenesis RPC service on start, which requires admin rights; thus, Run as Administrator is recommended. That menu option changes only the privilege token assigned to the SCC Manager process; unlike the reduced-privilege token, it is a full-privilege token. The Windows user account that runs the process is still the user account; it does not change to LocalSystem or any other built-in Windows account. The "Run as Administrator" menu option does not affect the NuGenesis account as saved into the NuGenesis AA, DM, and TE module configurations.

id11755, SDMS, SDMS8, SDMS8NU, SUPISDMS, SUPNG

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