Extended logging for NuGenesis 9 Data Adapter Release 4, Empower Remote Data Adapter enabled by default - WKB117637
SYMPTOMS
- Two log files on Empower Remote Data Adapter Server in C:\logs can grow extremely large in size due to activity of the Empower Remote Data Adapter:
C:\logs\traces.svclog
C:\logs\TraceDM.svclog
ENVIRONMENT
- NuGenesis 9 SDMS
- NuGenesis 9 Data Adapters Release 4
CAUSE
Extended logging was accidentally left enabled by default.
FIX or WORKAROUND
- Remove the entire <system.diagnostics> section from the following two config files to stop it writing to the log files (make a backup of the file before editing it.):
- Drive:\Program Files (x86)\Waters\NGSDMS\EVS\Waters.SDMS.WindowsService.exe.config
- Drive:\Program Files (x86)\Waters\NGSDMS\EVS\Waters.SDMS.WindowsServiceDM.exe.config
- Restart the Waters DataExchange services after editing and saving the config files.
ADDITIONAL INFORMATION
Here is a link to a Microsoft article on the subject:
https://docs.microsoft.com/en-us/dot...guring-tracing
The following is an example of the <system.diagnostics> section from the config file:
<system.diagnostics>
<sources>
<source name="System.ServiceModel" switchValue="Verbose, ActivityTracing" propagateActivity="true">
<listeners>
<add name="xml"/>
</listeners>
</source>
<source name="System.ServiceModel.MessageLogging">
<listeners>
<add name="xml"/>
</listeners>
</source>
<source name="myUserTraceSource" switchValue="Information, ActivityTracing">
<listeners>
<add name="xml"/>
</listeners>
</source>
</sources>
<sharedListeners>
<add name="xml" type="System.Diagnostics.XmlWriterTraceListener" initializeData="C:\logs\TracesDM.svclog"/>
</sharedListeners>
</system.diagnostics>
id117637, SDMS, SDMS8, SDMS8NU, SUPISDMS, SUPNG