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Error: "Could not load assembly 'Waters.Logging.Lib, Version=9.0.0.0, ..." appears when using a NuGenesis Smart Builder form - WKB111125

Article number: 111125

SYMPTOMS

  • The following error message appears when using a function in a NuGenesis Smart Builder form:
    • Could not load file or assembly 'Waters.Logging.Lib, Version=9.0.0.0, Culture=neutral, PublicKeyToken=a02071f9b59d9b41' or one of its dependencies.  The located assembly's manifest definition does not match the assembly reference.  (Exception from HRESULT: 0x80131040)

ENVIRONMENT

  • NuGenesis 9 LMS

CAUSE

Either some of the NuGenesis client components have not been installed.updated to the expected version, or a Smart Builder plugin expects an older version of a NuGenesis client program file.

FIX or WORKAROUND

  1. Ensure that the NuGenesis LMS client, Smart Builder, LMS SDK, Smart Builder Extensions are all installed and at the same version
  2. If this error occurs when clicking a specific cell or function in the form, then open the form in design mode and identify the DLL for that cell/function.  The version of that DLL present on the client is out of date and needs to be upgraded to the latest available version.  This issue ocurs most often with DLLs as provided by the Waters Professional Services group, as those DLLs are installed on an as-needed basis and not included with the standard LMS installation.  Contact Waters Technical Support for the latest version of the DL
  3. Look for old copies of the DLL in the main Smart build plugins folder, Drive:\Program Files (x86)\Waters\NuGensis LMS Smart Builder\Plugins.  SB will search this folder first for the plugin, even if the plugin is installed in a separate folder and recorded in the registry: HKLM\Software\Wow6432Node\Waters\Laboratory Execution Method Editor\Plugins

ADDITIONAL INFORMATION

 

id111125, NGLMS, NGLMSLIC, NGLMSOPT, SUPNG

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