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GPU error with the Compression, Noise Reduction, and Archival Tool - WKB7901

Article number: 7901

SYMPTOMS

  • When trying to noise-reduce HD-MSe data using Waters Compression, Noise Reduction, and Archival Tool version 1.10 (SCN 968), the software reports that no suitable GPU processor can be found
  • Because HD-MSe noise reduction depends on a suitable CUDA-enabled GPU being installed, noise reduction fails

ENVIRONMENT

  • Lenovo P720 Dual GPU processing PC (both the PLGS specification, and the Nonlinear Stage 1 LM specification with either Quadro P5000 or Quadro RTX 5000 data processing GPU)
  • Lenovo P520 Dual GPU P520 processing PC (Nonlinear LM Stage 2 specification with either Quadro P5000 or Quadro RTX 5000 data processing GPU)
  • Windows 10 Enterprise Edition LTSB 2016
  • C30 PLGS processing PC (Dual CPU, Quadro / Tesla dual GPUs, 64GB RAM)
  • D20 PLGS processing PC (Dual CPU, Quadro / Tesla dual GPUs, 24GB RAM)
  • Windows 7 Professional 64-bit
  • Waters Compression, Noise Reduction, and Archival Tool version 1.10 (SCN 968)
  • Data processing GPU meets the minimum specificationss listed in the SCN 968 release notes
  • If using a Tesla GPU, it has been correctly configured with Tesla compute cluster (TCC) enabled, and error correction (ECC) disabled
  • Maximus has been correctly configured using just the Quadro GPU driver

CAUSE

The error message is misleading. Investigation by GSS and software development shows this to be a file permission error masquerading as a GPU hardware issue. It occurs in two known circumstances:

1 - When logged in to the PC with a user account other than the administrator account

2 - When logged in to the administrator account, but where Windows Control Panel > User Account Control for the admin account was set to something other than "Never Notify"

FIX or WORKAROUND

  1. Determine if the account being used is the Administrator account.
  2. If the user account is not the Administrator account:
    1. Close SCN 968.
    2. Log out of the user account.
    3. Log in to the PC's administrator account.
    4. Start SCN 968.
    5. Repeat noise reduction.
  3. If the user account is the Administrator account and the problem still occurs:
    1. Close SCN 968.
    2. Open the Windows Control Panel from the Start menu.
    3. Open User Accounts.
    4. Select "Change User Account Control Settings".
    5. Move the slider down to "Never Notify".
    6. Start SCN 968.
    7. Repeat noise reduction.

ADDITIONAL INFORMATION

Using 'Run as Administrator' when starting SCN 968 may or may not help. It has worked on some PCs, but on the majority as of this writing it did not allow the user to use the noise reduction functionality with HD-MSe data.

In testing, only noise reduction of HD-MSe data was affected by this issue.

id7901, SCN968, SUPPLGS

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