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When launching Empower on a new client install, a error occurs even though the TNSnames.ora file is on the client: Enter the service name of the database you wish to connect to.

Article number: 96089

SYMPTOMS

  • When launching Empower on a new client an error occurs:
    • Enter the service name of the database you wish to connect to. If you are not using a naming service you may need to define the service name using the Net Configuration Assistant.
  • TNSnames.ora file onto the client is copied from a working client to the correct file location (Example: C:\Empower\Oracle\Oracle19cclient\network\admin) 
  • TNSnames.ora file contains the correct database information and service name
  • TNS ping is successful from the client

ENVIRONMENT

  • Empower 3
  • Empower Enterprise

CAUSE

The client install was not reading the TNSnames.ora file. 

FIX or WORKAROUND

  1. Type in the name of the database service name on the log-in window of Empower
  2. Log in.
  3. The service name will now be listed in the drop down when a user logs in

ADDITIONAL INFORMATION

This message may occur if the TNS_ADMIN environment variable is set on an Empower client machine and the variable points to the wrong path.  Empower doesn't use set this variable by default on install, but it can be set by users ofr the installers for other Oracle client software, such as the NuGenesis Oracle client.  One can set this system envionment variable in Windows to the Empower Oracle client's home path, and then Empower should be able to find tnsnames.ora.

id96089, EMP2LIC, EMP2OPT, EMP2SW, EMP3GC, EMP3LIC, EMP3OPT, EMP3SW, EMPGC, EMPGPC, EMPLIC, EMPOWER2, EMPOWER3, EMPSW, SUP

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