Skip to main content
Waters

When updating an Empower 3 server from FR4 to SR3, the Empower database upgrade prompt password fails for the Oracle "Sys" account - WKB52602

Article number: 52602

SYMPTOMS

  • When updating an Empower 3 server from FR4 to SR3, the Empower database upgrade prompt password fails for the Oracle "Sys" account
  • Neither the normal Oracle Sys account nor the EMPOWER3CSUPDATE password works
  • The text of the prompt is:
    • Empower 3 Service Release 3 - InstallShield Wizard
    • Password
    • This setup has been password protected
    • To complete the Empower database upgrade, you must specify the Oracle Sys account password. Please enter the password in the field below, and then press Next

ENVIRONMENT

  • Empower 3 Feature Release 4 upgrade to Service Release 3

CAUSE

Mismatch between the server's tnsnames.ora file alias and oracle sid for the database

OR

Person installing Empower 3 FR4 was not an administrator.

FIX or WORKAROUND

1. Rename the tnsnames.ora file in Empower\oracle\Oracle12cClient\network\admin directory to tnsnames.old.

2. Edit the tnsnames.old file and change the alias to the Oracle Sid (may be WAT10, WAT11, or WAT12).

    (Check by running lsnrctl status at the command prompt (DOS). The SID will usually be in the service name.

3. Save the tnsnames.old as tnsnames.ora.

4. Copy the tnsnames.ora to the Empower\Oracle\Oracle12c\Network\Admin directory, replacing the old tnsnames.ora,

5. Install Empower 3 SR3.

6. After installation, rename the tnsnames.old to tnsnames.ora to return to the original alias name.

7. Copy the new tnsnames.ora to the directory noted in step 4.

 

ADDITIONAL INFORMATION

clipboard_e8f2402792c3e602236a2da9a5c40e754.png

id52602,

Not able to find a solution? Click here to request help.