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Database connection terminated ORA-03135 seen on LAC/E with Azure Database server - WKB264945

Article number: 264945

SYMPTOMS

  • "Database connection terminated ORA-03135" when the logged in on LAC/E after 65 minutes inactive
  • Buffering is seen if acquisition time is greater than 65 minutes
  • ORA-03135 is not seen in Citrix sessions
  • Neither ORA-03135 nor buffering is seen for acquisition times less than 65 minutes

ENVIRONMENT

  • Empower 3.6.1 (any version could be impacted)
  • Azure database server
  • Azure Citrix
  • Azure raw data fileshare

CAUSE

Azure policies close idle TCP connections from external computers (LAC/E) after 65 minutes of inactivity. ORA-03135 indicates that something external to Oracle closed the connection.

FIX or WORKAROUND

There are only two options. Empower SQL TCP connections to the database are active only at injection start and end.

  1. Set the SQLNET.Expire_Time (see Empower, frequent buffering multiple sites, multiple LAC/Es - WKB229311). However, empty packets may be dropped/ignored.
  2. Set TCP KeepAlive on the servers. This will send ACK packets to open connections that are not ignored. Open but idle connections should respond.

ADDITIONAL INFORMATION

The default TCP keepalive time interval in Windows is 2 hours. If other things are set to timeout with lower values, TCP keepalive will not be initiated.

After a period (KeepAliveTime) of inactivity, the server will send ACK packets at specified intervals (KeepAliveInterval) up to the maximum number specified.

TCP KeepAlive registry keys to set on the servers:

   HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\

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