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"Database Connection Failed" error during Empower login - WKB17329

Article number: 17329

SYMPTOMS

  • User can log in (depending on the timing; see other symptoms)
  • After a while, if the same user or another user tries to log in to Empower, they get an error:
    Database Connection Failed !!
    ORA-12516: TNS. listener could not find available handler with matching protocol stack
  • During troubleshooting with SQLPLUS, an additional error was found:
    ERROR:
    ORA-00020: maximum number of processes (500) exceeded 
  • Restarting the database or the service OracleServiceWAT10 enables login for a while 

ENVIRONMENT

  • Empower 3 FR2 (Enterprise)

CAUSE

The Oracle Enterprise Manager (OEM) is not working as expected.

Processes are merely growing, and after some time the upper limit is reached. You can increase the value for the number of processes, but that will only delay the error.

FIX or WORKAROUND

  1. Disable the service OracleDBConsole

ADDITIONAL INFORMATION

The OEM goes away in future versions of Oracle and Empower 3, so the recommendation is to disable the service..

id17329, EMP2LIC, EMP2OPT, EMP2SW, EMP3GC, EMP3LIC, EMP3OPT, EMP3SW, EMPGC, EMPGPC, EMPLIC, EMPOWER2, EMPOWER3, EMPSW, SUP

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