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Dates are displayed incorrectly in Empower result audit viewer - WKB112365

Article number: 112365

SYMPTOMS

  • Dates display incorrectly in result audit viewer

ENVIRONMENT

  • Empower
  • Result audit viewer

CAUSE

The regional settings format was not set to English (United States) as detailed in the Empower installation, configuration, and upgrade guide, and the short or long date format is set differently than when the data was acquired and/or processed.

New Settings (FR5)clipboard_e801448b92b50f5a470c688eed87ee36c.png      Old settings (FR2) clipboard_e6445fa1244fce9bf4701fbf73464c3df.png

FIX or WORKAROUND

  1. Set the region format to English (United Sates), as described in the Empower installation, upgrade, and configuration guide.
  2. DO NOT USE the short date format yyyy-MM-dd, an option is to use dd-MM-yyyy.
  3. In Empower global system policies, on the Other tab, enable the following:
    • Use "long" date formats
    • Show Time Zone Offset*

*Tip: This policy is recommended for global companies with offices in different countries. It ensures that dates are recorded in the same format.
In addition to the time zone, you can also display the time zone difference (offset) from GMT (Greenwich Mean Time).

ADDITIONAL INFORMATION

This issue occurs because the dates of history strings such as the sample change history, sample set change history, and method revision history are stored as strings. When they are retrieved and converted to OraDate, they are not properly converted to OraDate when the current date format of the system does not match those of the stored date strings.

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