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Empower 3 FR4 installation fails with Windows blue screen error on Windows 10 Versions - WKB112294

Article number: 112294

SYMPTOMS

  • A Windows 10 blue screen "crash" occurs during Empower 3 FR4 installation
  • Error - PAGE FAULT IN NONPAGED AREA
  • Error - hardlock.sys
  • After computer restart, the Empower icon is present but the Empower installation is incomplete (e.g., Oracle may not be installed)

ENVIRONMENT

  • Empower 3 FR4
  • Empower 3 FR4 Enterprise client
  • Windows 10 Version 2004, OS Builds 19041 and 19042.685
  • Windows 10 20H2
  • Config 17 LACE with Windows LTSB 2021

CAUSE

This issue is due to an incompatibility with Windows 10 Version 2004 and the version of the License Manager component of Smartbear TestExecute 11 provided on the Empower 3 FR4 media.

FIX or WORKAROUND

  1. Remove Empower software.
  2. Download and install the SmartBear License Manager component from https://support.smartbear.com/testcomplete/docs/licensing/license-manager.html
  3. Install Empower 3 FR4.

ADDITIONAL INFORMATION

The SmartBear License Manager installer can be exited when the prompt for a user License Key comes up. At that point, the required License Manager component has already been installed, even though a license key isn’t going to be created or updated.

If installation of SmartBear License Manager failed with error 
"Installing license manager: Failed to execute with code 65584. The installation will rolled back"
clipboard_e3ce1aedf4634bb28db281892397b91da.png
Check Windows event viewer for error.
Open a command promp (cmd)
type netstat -aon
Check if port 1947 is in the list.
If port 1947 is in the list, read the last number (here 3376)
clipboard_e382f972ae10f8cb6132ba49057060a07.png

Go to task manager and kill process with the PID (in the example 3376)

clipboard_e9666e975fb34bde94e8afdc74ace7d24.png
Install SmartBear License Manager

After reboot, kill the process killed before the installation of SmartBear License Manager (in this example KService.exe) and start the Windows service "Sentinel LDK License Manager" 
After the installation of Empower 3 FR4, disable the Windows service "Sentinel LDK License Manager".

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