"UNIFI was unable to connect to the server" in WIP - WKB15021
SYMPTOMS
- When user connects to their Work in Progress tab, the error "UNIFI was unable to connect to the server" appears
- For one user, the server connection error appears immediately when they select Work in Progress
- For all other users with the correct permissions, selecting "view all users" in WIP results in the same server connection error
- The Portal cannot be recovered and must be killed from Task Manager
ENVIRONMENT
- UNIFI 1.8 workstation
- UNIFI 1.9.4 Workgroup
CAUSE
A corrupt item in the Work in Progress queue
CRI-153 - A work in progress item exists in the database without a name value
FIX or WORKAROUND
Contact GSS so they can resolve via direct SQL to remove the corrupt item.
This issue has been resolved in UNIFI 2.1.2 , the release notes have a typo for the CRI - it should be CRI-153 , not 1153
INFULA-3678 (CRI-1153) Previously, when you selected the All Users icon in the My Work > Work in Progress area when a work in progress item existed without a name value, an error loop occurred. Now, the error is resolved and UNIFI assigns a default name to the record without a name in the database. The record is listed as No Name - Save as or discard item in the My Work > Work in Progress area results.
ADDITIONAL INFORMATION
CRI-153 entered for this issue (previously reported as US1#212891)
id15021, SUPUNIFI, UNIFISVR, UNIFISW18, UNIFOPT, UNIFQLIC, UNIFSW17, UNIFSW18, UNIFSW19, UNIFWGLIC, UNIFWKLIC