Cannot log in to NuGenesis LMS; "DEPLOYMENTS IN ERROR" appears in the server.log file - WKB78521
SYMPTOMS
- Users get an error message when trying to log in to NuGenesis LMS:
- There was no endpoint listening at http: //servername:8180/vp/services/LoginWsService that could accept the message
- The NuGenesis LMS Server service is started on the machine name in the URL given in the error message
- The following error message is seen in the LMS server's log file:
-
2019-10-07 22:01:57,672 ERROR [ProfileServiceBootstrap] (Thread-2) Failed to load profile:: org.jboss.deployers.client.spi.IncompleteDeploymentException: Summary of incomplete deployments (SEE PREVIOUS ERRORS FOR DETAILS):
DEPLOYMENTS IN ERROR:
Deployment "vfs:///D:/WatersELNServer/Jboss-6.0....ecurity-mx.sar" is in error due to the following reason(s): java.lang.NullPointerException
Deployment "vfs:///D:/WatersELNServer/Jboss-6.0....deploy/eln.ear" is in error due to the following reason(s): javassist.NotFoundException: com.creon.common.security.LoginResult
-
ENVIRONMENT
- NuGenesis 9 LMS
- NuGenesis 8 LMS
- NuGenesis 8 ELN
CAUSE
An invalid session file was created in the LMS server. This invalid session file prevents the server from starting and listening on port 8180.
FIX or WORKAROUND
- Go to the sessions folder in the LMS server.
- Example: Drive:\WatersLMSServer\Jboss-6.0.0.Final\SessionFiles
- Look for a file named "-sessions.store". Delete this file or move it out of the SessionFiles folder.
- Restart the LMS Server service.
ADDITIONAL INFORMATION
Software defect (D_300127_05323) fixed in NG8 FR1
id78521, ELN, NGLMS, NGLMSLIC, NGLMSOPT, SUPNG