Skip to main content
Waters

Unable to save documents in NuGenesis LMS - WKB68056

Article number: 68056

SYMPTOMS

  • When creating documents in LMS, clicking the Save button results in an error message with the Oracle error code ORA-17002 or ORA-17008
  • When the Document Creator Service attempts to create a document from a template, the document creation fails with an error message in its log file:
    • System.Runtime.Serialization.SerializationException: Type 'com.creon.erm.common.SystemException' in assembly 'Creon.Common, Version=9.0.0.0, Culture=neutral, PublicKeyToken=60295abef4ad5d24' is not marked as serializable.
  • This issue is reproducible with specific document templates in LMS
  • Users may be unable to add images larger than 100KB to LMS document sections

ENVIRONMENT

  • NuGenesis 9 LMS
  • Oracle 12.2 / 19c

CAUSE

A defect in Oracle Database 12.2 and 19c.

FIX or WORKAROUND

  1. Oracle has documented this bug in their knowledge base with the ID 2399524.1.
  2. The recommended workaround is to add two parameters to the LMS server's configuration file.
  3. On the LMS server, edit the file Drive:\WatersLMSServer\javaServiceWrapper\conf\wrapper-jboss.conf in Notepad.
  4. Copy the following lines into the wrapper-jboss.conf file in the section "# Java Additional Parameters". Adjust the numbering in these lines to match that in the configuration file:
    • wrapper.java.additional.11=-Doracle.net.useZeroCopyIO=false
    • wrapper.java.additional.12=-Doracle.net.keepAlive=true
  5. Save and close the file.
  6. Restart the NuGenesis LMS server service.

ADDITIONAL INFORMATION

Defect report CRI-588 was filed for this issue.

Defect report CRI-2100, which concerns Jasper reports in LMS and database links, also requires the configuration changes as described in the Fix/Workaround section.  If those parameters are not in place, or if the "oracle.jdbc.ReadTimeout" parameter is set in NuGenesis LMS, then errors will occur when running Jasper reports in LMS which use DB links.  The error message is: "IJ031040: Connection is not associated with a managed connection".

This is the Oracle knowledge base article: https://support.oracle.com/knowledge/Middleware/2399524_1.html

id68056, NGLMS, NGLMSLIC, NGLMSOPT, SUPNG

Not able to find a solution? Click here to request help.