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Error "A web session must be established before calling this method" appears and/or InSpector becomes unresponsive when opening a JCAMP file from NuGenesis WebVision in InSpector - WKB31429

Article number: 31429

SYMPTOMS

  • When clicking on a JCAMP file in SDMS WebVision, the file opens in the InSpector client, but InSpector itself is unresponsive
  • After two minutes, the following message appears:
    • A Web session must be established before calling this method.

ENVIRONMENT

  • NuGenesis 8 SDMS

CAUSE

The InSpector client connects to the SDMS Web server when a file is opened from SDMS WebVision. This connection attempt fails due to an invalid certificate configuration in the Web server. The certificate may be missing, expired, or a self-signed certificate.

FIX or WORKAROUND

  1. Install a valid certificate from a CA that is trusted by all servers and clients in the domain. Self-sign certificates are not recommended.
  2. If it is not possible to obtain a valid certificate, edit the following registry key, which will disable the SDMS integration in InSpector:
    • Path: HKLM\Software\Wow6432Node\NuGenesis Technologies Corp.\NuGenesis\8.0\Viewers\InSpector
    • Name: CmdLine
    • Type: REG_SZ
    • Value: /SDMS "%s" %d
  3. Set that key's value to:
    • "%s" %d
  4. Close any open InSpector windows.

ADDITIONAL INFORMATION

The "/SDMS" command-line switch instructs InSpector to connect to the NuGenesis Web server on startup. This option allows users to upload data from InSpector to SDMS as annotation attachments to the original file. Without this parameter, the SDMS upload option is not available, and InSpector does not attempt to connect to the NuGenesis services on startup.

id31429, SDMS, SDMS8, SDMS8NU, SUPISDMS, SUPNG

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