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Error "Failed to connect to Oracle database" appears when using the NuGenesis LMS Toolbox - WKB29852

Article number: 29852

SYMPTOMS

  • The following message appears when exporting or importing data via the NuGenesis LMS Toolbox:
    • "Failed to connect to the Oracle database"
  • The Oracle Service selected in the Toolbox interface is valid and the database itself is running

ENVIRONMENT

  • NuGenesis 8 LMS
  • NuGenesis 8 ELN

CAUSE

  1. An Oracle client (such as the Waters Oracle Client supplied with NuGenesis) is installed but the service name selected is not in the client's tnsnames.ora.
  2. An incorrect password for the ELNPROD user was specified in the Toolbox.

FIX or WORKAROUND

  1. Verify the Oracle client configuration:
    1. Run the Waters Net Configuration Assistant from the Start menu or Start screen.
    2. The "Oracle Service" selected in the Toolbox must match an alias in the client's tnsnames.ora file.
      1. Example: if "SDMS8.WORLD" is selected in the Toolbox, then the Configuration Assistant must have an entry where the Alias is "SDMS8"
    3. Create an entry in the file if one does not exist with the selected Alias
      • Often, the correct database host, service name, and port number will be in the file, but with a different name.
      • In this case, create a new line, specify the correct alias, and copy the host name, service name, and port number from the existing entry.
    4. Save the modified configuration.
  2. Specify the correct password for ELNPROD.
    1. The "User" list in the toolbox displays a list of the Oracle accounts in the database. Only "ELNPROD" should be used with the Toolbox.
    2. Specify the correct password for ELNPROD in the password box.
    3. The password defaults to "elnprod", but this is not the default password for the ELNPROD account in NuGenesis 8.
    4. Click the Next button to verify connectivity with the database.
  3. If the connection to the database still fails, look in the Toolbox log file for more information.
    1. The default log file location is %TEMP%\Toolbox.log.
    2. Look in the file ELNToolbox.exe.config, in the Toolbox installation folder, for the path to the log file.

ADDITIONAL INFORMATION

The Toolbox brings the list of Oracle Services from the configuration files as configured in the Toolbox via the Set Preferences menu. This path is often the Oracle Home path of the NuGenesis Oracle server, or at least a full Oracle 11g client home. When the Toolbox attempts to connect to the database for the export or import, it does so via the TNS_ADMIN system variable. This variable often points to a different Oracle client installation—such as the Waters Oracle Client for NuGenesis—than the Oracle Home as configured in the Toolbox. Ensure that the tnsnames.ora and sqlnet.ora files in all Oracle clients have the same connect information for the NuGenesis databases.

id29852, NGLMS, NGLMSLIC, NGLMSOPT, SUPNG

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