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"TNS: could not resolve the connect identifier specified" error when logging in to NuGenesis SDMS applications - WKB27661

Article number: 27661

SYMPTOMS

The following error message appears when attempting to log in to NuGenesis SDMS applications:

"[NG14529] ODBC driver reports error: :[Oracle][ODBC][Ora]ORA-12154: TNS:could not resolve the connect identifier specified"

ENVIRONMENT

  • NuGenesis 9 SDMS
  • NuGenesis 8 SDMS

CAUSE

  • ".WORLD" is missing from the Oracle tnsnames file alias name;
  • Or, the tns_admin system variable is not present;
  • Or, the server name in the SDMS Master List does not match the TNS alias

FIX or WORKAROUND

  1. Navigate to the tnsnames.ora file at <Oracle_Home>\NETWORK\ADMIN.
  2. Add ".WORLD" to the alias name.
  3. Save and close the tnsnames.ora file.
  4. For SDMS Administrator, delete or remove the NGLocalProjectList.xml file, then restart SDMS Admin.  Click No when prompted.  Once in SDMS Administrator, ensure that the TNS alias - for example, "SDMSPROD" - is in the MAster List.  Click Actions \ Server \ Add if not in the list

ADDITIONAL INFORMATION

The message "could not resolve the connect identifier specified" means that the ORacle client could not map the name to a full connect string. This mapping normally happens in the tnsnames.ora file, subject to the parameters in the client's sqlnet.ora file. If there is a mismatch between the alias name and the name entered in the system DSNs—for example, "SDMS" in the tnsnames file vs. "SDMS.WORLD" in the system DSN—this error will occur. Or, if the TNS_ADMIN system variable is not present, the ORacle client may not be able to find the tnsnames.ora file, leading to the same message but for a very different reason.

id27661, SDMS, SDMS8, SDMS8NU, SUPISDMS, SUPNG

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