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NuGenesis Vision Browser shows "an error has occurred on the server" on launch - WKB25459

Article number: 25459

SYMPTOMS

  • NuGenesis Vision Browser displays the following error message:

"An error has occurred on the server:

0>=0

Please close your browser and try again. If the problem persists, contact your System Administrator."

ENVIRONMENT

  • NuGenesis 8 SDMS

CAUSE

The NuGenesis Vision Server process (NG80WVLS.exe) fails to start the NuGenesis Vision worker process (NG80WVPC.exe) because a WebVision.ini file is not present. 

FIX or WORKAROUND

A correct WebVision.ini file must be present in Drive:\Program Files (x86)\apache-tomcat-6.0.29\webapps\WebVision\ngvision. Either reinstall the NuGenesis Application Server component or copy the WebVision.ini file from a known-good SDMS server. In the latter case, make sure that the copied file contains paths that are appropriate for the server.

When the WebVision.ini file is in place, restart the following services:

  • Apache Tomcat 6.0.29
  • NuGenesis VISION Server

ADDITIONAL INFORMATION

This failure to launch VISION URL can also be due to a missing .dll.  C:\Windows\Syswow64\msvcr100.dll.  The NuGenesis Vision Server process (NG80WVLS.exe) fails to start the NuGenesis Vision worker process (NG80WVPC.exe).

NuGenesis RPC Service will also fail to start for the following reason.  Copy the .dll from a working system.  NuGenesis RPC Service will now start.  

Restart the VISION Services and then VISION will also load successfully because NG80WVPC.exe now also running.

id25459, SDMS, SDMS8, SDMS8NU, SUPISDMS, SUPNG

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