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The NuGenesis SDMS Archive Agent does not start and does not write to a log file - WKB251394

Article number: 251394

SYMPTOMS

  • The Archive Agent module does not start in the NuGenesis Service Configuration Console (SCC)
  • The AA does not write its normal log file, NGSDMSAAActivity.log
  • The Auto IQ log file for the SDMS File Capture components is clean, no errors or warnings

ENVIRONMENT

  • NuGenesis 9 SDMS
  • NuGenesis 8 SDMS

CAUSE

One DLL file, NGArchiveAgentDll.dll, is not registered.

FIX or WORKAROUND

  1. Stop the NuGenesis RPC service.
  2. Register the DLL in a command prompt with Admin rights:
    • NuGenesis 9: C:\Windows\Microsoft.Net\Framework\v4.0.30239\regasm.exe "Drive:\Program Files (x86)\Waters\NGSDMS\Common Files\NGArchiveAgentDLL.dll" /codebase /verbose
    • NuGenesis 8: C:\Windows\syswow64\regsvr32.exe "Drive:\Program Files (x86)\NuGenesis 8.0\Common Files\NGArchiveAgentDll.dll"
  3. Restart the NuGenesis RPC service.
  4. Log in to the SCC to determine if the AA module started.

ADDITIONAL INFORMATION

NuGenesis 9 requires a different procedure for registering the DLL because the code was rewritten to use Microsoft.NET Framework, which makes the NG9 version of the DLL a .NET assembly. Such DLLs lack the "DllRegisterServer" function and are therefore incompatible with regsvr32.exe. The NG8 version of the file does not use .NET Framework and therefore is registered with regsvr32.exe.

Enhancement request CRI-5410 was filed for this issue.

id251394, SDMS, SDMS8, SDMS8NU, SUPISDMS, SUPNG

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