Error "Could not connect to the server provided. Please check the network connection or the database configuration" appears when loading the new NuGenesis SDMS WebVision site - WKB239342
Article number: 239342
SYMPTOMS
- The following message appears in red text on the login page for the new WebVision Web app for SDMS:
- Could not connect to the server provided. Please check the network connection or the database configuration.
- The list of servers on the WebVision Web app's login page is empty
- In the Developer Tools in Edge or Chrome, the network trace shows no response from the Web server for the "project-servers" request
- The same entry in the network trace shows the valid server name in the request URL
ENVIRONMENT
- NuGenesis 9.3 or later
- New WebVision loaded in a supported Web browser
CAUSE
The "SdmsProjectServers" site in IIS is bound to HTTPS at port 54824, and the site is started (listening on the port), but it does not have a certificate selected. OR, the certificate is expired. OR, the fully qualified domain name of the Web server is specified in the envConfig.json file for the main WebVision site.
FIX or WORKAROUND
- Certificates:
- Open IIS Manager on the SDMS Web server.
- Click the Sites entry in the list.
- Double-click the SdmsProjectServers site.
- Select the https binding and click Edit.
- Select a valid certificate from the drop-down list.
- If there are no certificates, or no valid certificates, in IIS, see WKB17988 for instructions on creating a self-signed certificate. After creating the self-signed certificate, follow steps 1 through 5 to assign the certificate to the site.
- Repeat these steps for all "sdms" sites in IIS.
- envConfig.json file:
- Open the following file in Notepad with Admin rights:
- Drive:\Program Files (x86)\Waters\NGSDMS\Application Server\Vision\SdmsVision\assets\config\envConfig.json
- Ensure that only the Web server's hostname is in the "hostname" field in the file.
- Specify the Web server's domain name in the "domain" field.
- Save and close the file.
- Open the following file in Notepad with Admin rights:
- Clear the Web browser's cache and reload the WebVision site.
ADDITIONAL INFORMATION
id239342, SDMS, SDMS8, SDMS8NU, SUPISDMS, SUPNG