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NuGenesis prompts "OlePictureFormatPreferenceList key not present in registry" and "Install the NuGenesis Transfer App" after Windows upgrade - WKB233200

Article number: 233200

SYMPTOMS

  • After upgrading a NuGenesis LMS Client's OS from Windows 10 1909 to 20H2, or from Windows 10 to 11, users receive the following prompts:
    • The following message appers after logging in to the LMS Client or when opening LMS documents:
      • OlePictureFormatPreferenceList key not present in registry.

        Do not edit or create any documents, templates or sections until this is resolved.

        Run the NuGenesis LMS application with administrator rights to solve the issue.

        This operation must be done only once.

    • Prompted to install the NuGenesis Transfer Application when attempting to preview a report or download a file from WebVision, and the Transfer App is already installed on their PC
       

ENVIRONMENT

  • NuGenesis 9 LMS

CAUSE

These messages are received due to changes in the Windows registry during the Windows upgrade. Specifically, the Multi-String value OlePictureFormatPreferenceList in "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\ Session Manager" is missing and the Internet Explorer browser does not include "application/nugenesis-sdms" in the Accept header of the HTTP requests to the NuGenesis Web server.
 

FIX or WORKAROUND

  • OlePictureFormat not present:
    • Automated method:
      1. Close the LMS client
      2. Right-click the LMS Client shortcut and choose Run as Administrator
      3. Log in to the LMS Client
      4. Close the LMS client
      5. Run and log in to the LMS client as normal
    • Manual method:
      1. Within "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager", add the Multi-String value OlePictureFormatPreferenceList with the value data:
        • ENHMETAFILE
        • METAFILE
        • DIB
        • BITMAP
      2. Close and reopen the LMS Client
  • 2. SDMS Transfer App: see KCS article "Prompted to install the NuGenesis Transfer App when it's already installed - WKB967" for the method to fix this incorrect prompt. 

ADDITIONAL INFORMATION

 

id233200, NGLMS, NGLMSLIC, NGLMSOPT, SDMS, SDMS8, SDMS8NU, SUPISDMS, SUPNG

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