Skip to main content
Waters

"No data found for the specified criteria" message appears when applying a filter in the Reagents/Instruments inventories in NuGenesis LMS - WKB231774

Article number: 231774

SYMPTOMS

  • No rows are found for filter criteria even though one or more substances should be part of the search results
  • The following message appears on the LMS client:
    • No data found for the specified criteria. Right-click here to clear the current filter.

ENVIRONMENT

  • NuGenesis 9 LMS
    • NuGenesis 9.1, 9.2

CAUSE

The maximum number of records is less than the number of records that match the search criteria. The default limit on the number of records returned is 300.

FIX or WORKAROUND

  1. Click the menu button for the view selection list and click Detailed.
  2. Click on the text "Retrieve first X records".
  3. Set a new, higher number for the limit.
  4. Click OK.
  5. Click the Search button.
  6. Reapply the filter.

ADDITIONAL INFORMATION

The filter criteria apply only to the rows as returned by the search query. For example, in the "Active" view, the search query is "Active Is True", and by default only the first 300 active substances are shown. Any filters added to the table will operate on only those 300 records in the table, NOT on the entire result set of the search query.

This issue does not affect NuGenesis 9 LMS versions 9.0.x; the new user interface was introduced for the Instrument and Reagent inventories in NuGenesis 9.1.

id231774, NGLMS, NGLMSLIC, NGLMSOPT, SUPNG

Not able to find a solution? Click here to request help.