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Error "[NG17538] Unable to create LDAP session" occurs when using the NuGenesis SDMS SDK to log in to SDMS via LDAP/TLS - WKB209611

Article number: 209611

SYMPTOMS

  • The following error message is returned by the SDMS SDK when logging in with valid LDAP credentials:
    • [NG17538] Unable to create LDAP session

ENVIRONMENT

  • NuGenesis 9 SDMS
  • TLS is enabled in SDMS for LDAP authentication

CAUSE

The SDK application does not have rights to access the CACerts.cer file in the NuGenesis SDMS installation folder; or, the user has rights to that folder but the SDK app handles simultaneous user sessions.  In the latter case, the user sessions conflict over access to CACerts.cer, resulting in frequent NG17538 errors.

FIX or WORKAROUND

  1. For single-user SDK applications (that is, apps that are not expected to handle more than one user session at a time): grant Modify access on Drive:\Program Files (x86)\Waters\NGSDMS\Common Files to the Authenticated Users group.
  2. For multi-user SDK applications, the only viable workaround is to avoid the use of LDAP accounts with that app. Create Oracle accounts in the database for each user who needs access to the SDK app (the Oracle usernames must be distinct from the LDAP usernames). Assign the Oracle usernames to the matching SDMS user accounts in either SDMS Administrator or the SDMS Help Desk web app.

ADDITIONAL INFORMATION

Enhancement request CRI-3909 was filed for this issue.

id209611, SDMS, SDMS8, SDMS8NU, SUPISDMS, SUPNG

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